Directadmin multiphp kurulumu

Merhaba

Directadmin multi php kurmak için custumbuild kullanabiliriz.

ilgili modülü kurabilmek için apache sürümü 2.4 ve custom build 2.0 ya da daha üstü olması gerekmektedir.

DirectAdmin üzerinde php1 ve php2 olarak iki farklı php sürümü belirleyebilirsiniz.

Eğer yapımız apache üzerinde ise

cd /usr/local/directadmin/custombuild
./build set php1_release 5.4
./build set php2_release 5.6
./build set php1_mode php-fpm
./build set php2_mode php-fpm
./build update
./build php d
./build rewrite_confs
komutları sırası ile uyguluyoruz.
eğer nginx üzerinde ise
cd /usr/local/directadmin/custombuild
./build set mod_ruid2 no
./build set php1_release 5.4
./build set php2_release 5.6
./build set php1_mode php-fpm
./build set php2_mode php-fpm
./build update
./build php d
./build rewrite_confs
 komutları sırası ile uyguluyoruz.

Bir Cevap Yazın